Posts Tagged ‘Firefox’

Fixing Sound in Firefox on Vista

July 31, 2008

For about 4 days now I’ve been without any sound in Firefox. My operating system is windows vista, my IE sound worked just fine, and the only solutions I’ve found on the net involve the Wavemapper trick, reinstalling flash, using the K-Lite Codec Tweak or using CCleaner to fix it.
None of these worked for me, and I decided to try to fix it myself.

Now, given that I still had audio in IE, I knew my flash installation was okay, and that it’s not a Codec issue. I began to think to myself, ‘What did I do in Firefox that I haven’t done to I.E.’
I had turned the sound down before to mute flash game music, allowing me to hear my own. However, I had since turned the sound back up. I took a shot in the dark and renamed firefox.exe to firefoxFix.exe and that got me my sound back. What had happened is that despite my turning the sound back up, vista refused to correct the volume for firefox.exe. I then opened the registry, deleted the key holding firefox’s volume settings, restored firefox.exe to its original name, and voila, I had my audio back.

Edit: Below is the manual method of applying this fix. On December 23, 2009 I created a tool that will fix the problem with a few clicks. If you don’t want to go messing about in the registry, I suggest you use the easy method.

Update: With the release of Firefox 3.6.4, the management of flash audio has changed. I will be updating the tool and the manual method to reflect these changes.

The Easy Method:

Download Firefix

All you have to do is unzip the package, close all firefox windows and run firefix.exe. You should see a quick flash of a command window, but don’t worry if you don’t notice it. Now just start firefox again and test your audio on youtube.
This is designed to run on windows Vista and 7, please let me know of any problems you experience.

Note: This is NOT a full registry cleaner. It does not install any files to your computer. It runs a localized copy of python and has only one use. I created the tool to solve this specific problem. There is no risk, as if you do not have the bug you won’t notice anything remarkable happen. There were well over 200 downloads in the first month of this tool being available, and I’ve had no complaints yet.

The Manual Method:
The first thing you should do, before trying to apply my fix is to rename firefox.exe – the new name doesn’t matter. Once you’ve renamed it, head over to youtube and test your audio. If it still doesn’t work, then this is not the fix you’re looking for. Move along. If, however, your sound returns then you are in luck. Restore firefox.exe to its original name, and follow the instructions below.
Update: As of firefox 3.6.4, the renaming test doesn’t work due to the new flash container being used.

Now to share the fix with you in simple steps.

  1. Click your start menu and enter: Regedit.exe in your search bar and run it.
  2. Navigate to: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\LowRegistry\Audio\PolicyConfig\PropertyStore
  3. Press CTRL+F and enter firefox.exe
  4. In the bottom of the window, you will see the full key name containing the firefox entry. It will be similar to:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\LowRegistry\Audio\PolicyConfig\PropertyStore\f8ef7687_0
    Right click that key in the left pane of Regedit and delete it.
    – As of Firefox 3.6.4, you must also search for an delete the plugin-container.exe entry. Go to step 2, and proceed with this new file name.
  5. Enjoy your audio.

For those who need a little visual help, here’s a screenshot:

Update: Some users may have multiple keys holding Firefox data. Deleting them all seems to be safe.
– Thanks to Ray for the feedback.

In response to Fletchman’s Comment (I figured this was worth responding to up here.):
Fletch, this is a rather esoteric issue, in that it only affects people with firefox on vista that like to turn the sound off to shut up things like flash ads. It’s really the fault of Microsoft, not youtube or Adobe.
As for my solution’s availability, you should have seen what I went through to find it. When I had this problem NOBODY had the solution, I had to figure out what was wrong ang fix it myself. It took me 3 days. I’ve already gone and posted links to it in a bunch of forums that I crossed on my search for an answer, and now if you were to type Sound or audio and Firefox Vista into google, this is either the first or second item (Depending on the order of words.)
Even so, this is a request to everyone this solution helps: if you wouldn’t mind, I’d very much appreciate if you could post a link to this solution in a couple of threads you came across that didn’t have it. Hopefully that will make the lives of future victims of this problem 3 hours less hair-pullingly exciting. Thanks a lot to everyone for the positive feedback!

And there ya have it. Please post any questions or comments you may have for me.
I’m here to help!

Advertisements